Como remover as tags trailing / li do wp_nav_menu walker

2

Eu usei o tema vinte e treze do meu tema base e tentei usar o código de enlace quando tento validar a página recebo um erro com trailing </li> tags inválidas Estou tentando criar esse resultado a partir da classe walker

<div class="box1">
    <a href="#"><span class="click"></span></a>
</div>
<div class="box2">
    <h1 class="#">text</h1>
</div>
<div class="box3">
    <a href="#"><span class="click"></span></a>
    <h3 class="#">Text<span class="#">></span></h3>
</div>

Mas sempre acabam com tags </li> à direita, alguém pode ajudar com esse problema

Eu tentei isso primeiro

class Description_Walker extends Walker_Nav_Menu
{
    function start_el(&$output, $item, $depth, $args)
    {
        $classes = empty($item->classes) ? array () : (array) $item->classes;
        $class_names = join(' ', apply_filters( 'nav_menu_css_class', array_filter( $classes ), $item ) );
        !empty ( $class_names ) and $class_names = ' class="'. esc_attr( $class_names ) . '"';
        $output .= "<div id='menu-item-$item->ID' $class_names>";
        $attributes  = '';
        !empty( $item->attr_title ) and $attributes .= ' title="'  . esc_attr( $item->attr_title ) .'"';
        !empty( $item->target ) and $attributes .= ' target="' . esc_attr( $item->target     ) .'"';
        !empty( $item->xfn ) and $attributes .= ' rel="'    . esc_attr( $item->xfn        ) .'"';
        !empty( $item->url ) and $attributes .= ' href="'   . esc_attr( $item->url        ) .'"';
        $title = apply_filters( 'the_title', $item->title, $item->ID );
        $item_output = $args->before
        . "<a $attributes>"
        . $args->link_before
        . $title
        . '</a></div>'
        . $args->link_after
        . $args->after;
        $output .= apply_filters( 'walker_nav_menu_start_el', $item_output, $item, $depth, $args );
    }
}

e coloque isso no cabeçalho

wp_nav_menu(
    array (
        'menu' => 'main-menu',
        'container' => 'div', // parent container 
        'container_id' => 'my_nav', //parent container ID
        'depth' => 1,
        'items_wrap' => '%3$s', // removes ul
    'walker' => new Description_Walker // custom walker to replace li with div
    )
);

Eu tentei modificar esse código, mas todas as maneiras ficam atrás de </li> tags, você acha que poderia me apontar na direção certa? Trabalhei nesse problema por mais de uma semana. Outros parecem ter o mesmo problema e eu tentei o que foi sugerido, mas sem sucesso. pela maneira como este código foi fornecido pelo RCV

    
por user2033464 13.11.2013 / 21:34

2 respostas

3

apenas lemos um artigo sobre como remover <li> elements de wp_nav_menu ( enlace ) e o código sugerido é

$menuParameters = array(
  'container'       => false,
  'echo'            => false,
  'items_wrap'      => '%3$s',
  'depth'           => 0,
);

echo strip_tags(wp_nav_menu( $menuParameters ), '<a>' );

você tentou isso?

    
por Artful_dodger 16.11.2013 / 00:52
4

Você precisa fazer algo com a função end_el. Eu fiz um walker personalizado para gerar um menu de seleção e não obtive resultados limpos até que eu tenha sobrescrito o end_el e gerado a tag de opção de fechamento lá. Tentar fazer tudo em start_el () estava causando dores de cabeça.

Tente remover o div de fechamento dessa linha

. '</a></div>'

e mude para apenas fechar sua âncora assim.

. '</a>

substitua a função end_el assim

class Description_Walker extends Walker_Nav_Menu
{
    function start_el(&$output, $item, $depth, $args)
    {
        $classes = empty($item->classes) ? array () : (array) $item->classes;
        $class_names = join(' ', apply_filters( 'nav_menu_css_class', array_filter( $classes ), $item ) );
        !empty ( $class_names ) and $class_names = ' class="'. esc_attr( $class_names ) . '"';
        $output .= "<div id='menu-item-$item->ID' $class_names>";
        $attributes  = '';
        !empty( $item->attr_title ) and $attributes .= ' title="'  . esc_attr( $item->attr_title ) .'"';
        !empty( $item->target ) and $attributes .= ' target="' . esc_attr( $item->target     ) .'"';
        !empty( $item->xfn ) and $attributes .= ' rel="'    . esc_attr( $item->xfn        ) .'"';
        !empty( $item->url ) and $attributes .= ' href="'   . esc_attr( $item->url        ) .'"';
        $title = apply_filters( 'the_title', $item->title, $item->ID );
        $item_output = $args->before
        . "<a $attributes>"
        . $args->link_before
        . $title
        . '</a>'
        . $args->link_after
        . $args->after;
        $output .= apply_filters( 'walker_nav_menu_start_el', $item_output, $item, $depth, $args );
    }
    function end_el(&$output, $item, $depth) 
    {
        $output .= "</div>";
    }
}

Tenho certeza de que o problema é que você não está superando o end_el (), por isso está apenas fazendo o que quer e inserindo a tag li de fechamento.

    
por George Kendros 16.11.2013 / 02:03

Tags