Wordpress 3.9 Atualização do banco de dados Infinite Loop

8

Atualizei recentemente a versão do Wordpress do meu blog para 3.9. Depois de executar a atualização, recebi esta mensagem ao tentar acessar o painel de administração.

  

Atualização do banco de dados necessária

     

WordPress foi atualizado! Antes de enviarmos você pelo caminho, temos que   atualize seu banco de dados para a versão mais recente.

     

O processo de atualização pode demorar um pouco, então, por favor, seja paciente.

Eu sou apresentado então com um botão " Update Wordpress Database ". Quando clico no botão, após uma breve pausa, sou apresentada a seguinte mensagem.

  

Atualização concluída

     

Seu banco de dados WordPress foi atualizado com sucesso!

Ótimo. Só que sempre que eu tento acessar o painel de administração, sou apresentada novamente a primeira mensagem pedindo novamente para atualizar meu banco de dados.

Alguém sabe de uma saída desse loop infinito?

    
por Levi Botelho 18.04.2014 / 21:28

2 respostas

4

Eu tive isso em um dos meus sites recentemente (definido como núcleo de atualização automática, então não tenho certeza se em 3.9 ou um de 3.8. *). O cache de limpeza corrigiu isso - wp cache flush via wp-cli, imagino que outras formas funcionariam da mesma maneira.

    
por Rarst 18.04.2014 / 22:08
1

Isso se deve a uma falta de correspondência entre as versões do banco de dados que você disse estar usando nas configurações.

Por favor, siga os seguintes passos:

  1. Vá para a pasta /wp-include/ e abra o version.php .
  2. Encontre o valor para $wp_db_version e anote-o.
  3. Agora, abra seu banco de dados, verifique na tabela chamada wp_options
  4. Encontre o valor db_version :

    SELECT option_value FROM yourdatabase.wp_options WHERE option_name = 'db_version';

  5. Esses dois valores devem ser os mesmos . Altere-o no arquivo version.php , não no banco de dados.

Fonte: enlace
Fonte: enlace

    
por Francisco Corrales Morales 21.08.2015 / 22:21