Cookies em vários sites onde os sites da rede têm seu próprio nome de domínio

8

Eu decidi integrar vários sites independentes do Wordpress em uma única instalação multisite.

Eu criei uma nova instalação multisite com subdiretórios, criei um site de rede MU com o URL do subdiretório e exportei o conteúdo do site autônomo original e, em seguida, importei esse conteúdo para o site do subdiretório MU.

Em seguida, removi o site autônomo original do cPanel e defini o nome de domínio do site da MU para o nome de domínio original.

O site é carregado em seu nome de domínio original, mas quando tento efetuar login no domínioname.com/wp-admin (usando as novas credenciais de usuário administrador de rede do multisite), recebo um erro:

  

ERRO: os cookies estão bloqueados ou não são suportados pelo seu navegador. Você deve   permitir que os cookies usem o WordPress.

Os cookies são ativados no Chrome.

Eu tentei adicionar o seguinte a wp-config.php :

define('COOKIE_DOMAIN', false);

mas a questão permanece.

O mesmo problema ocorre se eu usar o WP Migrate DB Pro, para inserir um site autônomo em um site de subdiretório MU, excluir o site autônomo do cPanel e definir o URL do site do subdiretório MU como o domínio do site autônomo original. nome. O front-end do site é carregado, não consigo fazer login no administrador.

Ajuda apreciada.

    
por Steve 13.03.2017 / 06:09

10 respostas

10

Primeiro, desmarque o cache do navegador (incluindo cookies) + cache do servidor dos plug-ins do cache, etc.

Em seguida, defina o seguinte no seu arquivo wp-config.php :

define('ADMIN_COOKIE_PATH', '/');
define('COOKIE_DOMAIN', '');
define('COOKIEPATH', '');
define('SITECOOKIEPATH', ''); 

Além disso, você pode conferir a resposta AQUI :

define('WP_ALLOW_MULTISITE', true);
define('MULTISITE', true);
define('SUBDOMAIN_INSTALL', false);
define('DOMAIN_CURRENT_SITE', 'your-domain.com');
define('PATH_CURRENT_SITE', '/');
define('SITE_ID_CURRENT_SITE', 1);
define('BLOG_ID_CURRENT_SITE', 1);
define('SUNRISE', 'on');

Se ainda falhar, leia esta resposta ou entre em contato com o suporte do servidor, pode haver um problema de configuração no servidor.

    
por Scott 23.03.2017 / 11:04
3

Usando o WordPress versão 4.9.4.

Eu estava recebendo o erro de cookie e examinei várias opções de ajuda e, eventualmente, resolvi o problema usando uma combinação da correção de Scott:

Observação: não fiz nenhum cache de cookies

a) Editando sunrise.php line em wp-config.php (Eu estava usando o mapeamento de domínio nativo, removi as alterações de instalação do plug-in MU que eu fiz)

b) Ajustou meu wp-config.php para

/* Multisite */

define('WP_DEBUG', false);

define( 'WP_ALLOW_MULTISITE', true ); 

define('MULTISITE', true);
define('SUBDOMAIN_INSTALL', true);
define('DOMAIN_CURRENT_SITE', 'www.mysite.com.au');
define('PATH_CURRENT_SITE', '/');
define('SITE_ID_CURRENT_SITE', 1);
define('BLOG_ID_CURRENT_SITE', 1);
/* define( ‘COOKIE_DOMAIN’, $_SERVER[ ‘HTTP_HOST’ ] ); */

define('ADMIN_COOKIE_PATH', '/');
define('COOKIE_DOMAIN', '');
define('COOKIEPATH', '');
define('SITECOOKIEPATH', '');

/* That's all, stop editing! Happy blogging. */
    
por user140609 27.03.2018 / 21:33
1

Acabei de solucionar um problema semelhante com subdomínio multisite.

Com:

define('COOKIE_DOMAIN', $_SERVER['HTTP_HOST']);

O site ainda apresentava um erro de cookie e, em alguns casos, tentou o que foi sugerido acima .........

define('ADMIN_COOKIE_PATH', '/');
define('COOKIE_DOMAIN', '');
define('COOKIEPATH', '');
define('SITECOOKIEPATH', ''); 

Isso causou um erro diferente para excluir define referência "COOKIE_DOMAIN" ao visitar subsites.

Por fim, consegui fazer o login depois de ter certeza de que ambos foram definidos logo acima das informações de rede de vários sites

define('COOKIE_DOMAIN', $_SERVER['HTTP_HOST']);
define('COOKIE_DOMAIN', '');

Tente verificar se ambos estão definidos. Espero que isso ajude.

    
por Ruben Apolinar 06.12.2017 / 18:16
1

Eu comentei define ('SUNRISE', 'on');

/* define('SUNRISE', 'on'); */
define('COOKIE_DOMAIN', $_SERVER['HTTP_HOST']);
define('COOKIE_DOMAIN', '');

Então, não vejo a mensagem de erro abaixo:

ERROR: Cookies are blocked or not supported by your browser. You must enable cookies to use WordPress.

O login também começou a funcionar.

    
por Joone Hur 22.01.2018 / 23:35
1

Então, eu estava tendo esse problema também e encontrei muitas soluções como as mencionadas aqui, mas elas não funcionaram.

O que funcionou foi simplesmente adicionar o seguinte à configuração multisite em wp-config:

define('COOKIE_DOMAIN', false);

para que a seção em wp-config seja assim:

define( 'WP_ALLOW_MULTISITE', true );
define('MULTISITE', true);
define('SUBDOMAIN_INSTALL', true);
define('DOMAIN_CURRENT_SITE', 'your-site.com');
define('PATH_CURRENT_SITE', '/');
define('SITE_ID_CURRENT_SITE', 1);
define('BLOG_ID_CURRENT_SITE', 1);
define('COOKIE_DOMAIN', false);

postando aqui para que outros possam encontrá-lo e passar menos tempo batendo a cabeça contra a mesa do que eu.

    
por ronaut 09.05.2018 / 00:05
0
define('MULTISITE', true);
define('SUBDOMAIN_INSTALL', true);
//define('DOMAIN_CURRENT_SITE', 'masterdigitalservices.com');
//define('PATH_CURRENT_SITE', '/');
//define('SITE_ID_CURRENT_SITE', 1);
//define('BLOG_ID_CURRENT_SITE', 1);

Aqui está o meu novo wp-config. Parece que foi codificado para ser um site específico e não permitia que outros domínios funcionassem - apenas subdomínios. Grandes respostas aqui.

    
por Andy 31.03.2018 / 20:50
0

Eu estava tendo esse problema também, e nada que eu fiz ajudou. Tentei no Microsoft Edge, e não recebi o erro.

Portanto, no meu caso, foi apenas o Google Chrome que causou o problema.

    
por snake 30.04.2018 / 22:43
0

Estranhamente, funcionou para mim (em mais de um multisite) definir SUBDOMAIN_INSTALL como false. Para ser honesto, eu não tive tempo de investigar mais por que ...

define('SUBDOMAIN_INSTALL', false);

    
por Martin from WP-Stars.com 20.08.2018 / 11:47
0

ESTA FIXED IT FOR ME Eu não tinha configurado o WordPress totalmente para o novo nome de domínio. Eu criei meu site subdominio.dominio.com Então, quis permanecer como newdomain.com em subdominio.dominio.com Isso é necessário

  1. WordPress rede > admin > site , altere o site para o novo nome (que eu já tinha feito, o site estava funcionando)
  2. WordPress rede > admin > configurações > domínios , adicione um novo nome ao ID do site e assinale sim para o domínio principal (para indicar que esse nome é o nome principal). Para encontrar o ID do site, você pode passar o mouse sobre a rede > admin > site que vai dizer em qual ID do site você está trabalhando. Espero que isso ajude alguém que estava recebendo os cookies estão bloqueados ou não suportados mensagem ao tentar fazer o login Muitas felicidades SamTapsell
por sam tapsell 17.10.2018 / 15:04
-1

Por favor, tente adicionar o seguinte ao seu arquivo wp-config.php

Remova também todos os cookies do seu navegador antes de testar

define( 'COOKIE_DOMAIN', $_SERVER[ 'HTTP_HOST' ] );
    
por Dean Jansen 16.03.2017 / 14:38

Tags