Haverá atualizações de segurança para 3.1 quando 3.2 for lançado?

8

Atualmente, estou executando o WordPress 3.1.2 no PHP 5.1.6. O requisito mínimo para o WordPress 3.2 será o PHP 5.2.4 ou superior. Se eu continuar executando o WordPress 3.1.2 e houver um problema de segurança, eles fornecerão atualizações de segurança para o 3.1 ou serei forçado a atualizar minha versão do PHP para que eu possa atualizar para o WordPress 3.2?

    
por ejunker 20.05.2011 / 18:38

3 respostas

7

Atualizações de segurança de backports do WordPress geralmente de 1 a 3 versões, mas não prometem nada.

A filosofia LTS do WordPress é que LTS="Sucagem a Longo Prazo "

A teoria da sucção a longo prazo é:

  

Embora eu goste da teoria do LTS, o que   acontece na prática é encobre   a incompetência de TI ou desenvolvedores   porque eles adiam um pouco   upgrades dolorosos até que eles saiam tão fora   da data do tronco (3 anos? 5 anos?)   e você tem que passar por um gigante   doloroso, parafusos todo mundo   atualizar. - Matt Mullenweg

Como o seu administrador de sistemas não quer atualizar o PHP agora que ele tem 6 anos e 2 grandes ramificações.

Gostaria de apontar meu sysadmin para este tópico da lista de discussão RedHat de 2009 . Existem pacotes de terceiros disponíveis para que você não precise compilar a partir da fonte

  

Se a versão do php que você precisa não é   disponível em rhn você poderia usar algum   Repositórios de terceiros como rpmforge, ATrpms   ou o Repositório Remi Collet que é   feito especialmente para o mysql 5.1 e   php5.2.9 sob EL5.

Eu estaria mais preocupado com problemas de segurança de filiais do PHP 5.1 do que com algo que possa surgir com o WordPress.

Editar:

Também foi encontrado este anúncio oficial da RedHat de janeiro de 2011 RHEL 5 agora disponível no PHP 5.3.

    
por Chris_O 20.05.2011 / 19:43
8

Não, versões mais antigas não são atualizadas.

Afora: O PHP 5.1.6 tem cinco anos de idade. Mesmo que o WordPress ofereça patches para o 3.1.2 - você perdeu mais de 100 correções de segurança para o PHP, então o WordPress não é o seu principal problema.

    
por fuxia 20.05.2011 / 18:51
1

O WordPress não corrige versões mais antigas, portanto, você precisará atualizar ou aplicar manualmente as correções por conta própria.

    
por Wyck 20.05.2011 / 18:43

Tags