remove “index.php” dos permalinks

14

Eu tenho tentado encontrar uma solução. mas eu não posso ..

meus links são todos domain.com/index.php/post_name/

Eu realmente quero remover /index.php

Eu pesquisei e encontrei alguns ... dizendo que preciso adicionar esses ... mas não está funcionando ..

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

Estou usando a versão 3.5.2 wp.

Por favor, deixe-me saber se você sabe alguma coisa sobre isso.

    
por pulla 09.07.2013 / 07:44

2 respostas

17

Vá para o seu WP-ADMIN - > Configurações - > Permalink e use a alteração da estrutura do permalink, se ele gerar qualquer arquivo .htaccess , copie o conteúdo e atualize seu arquivo .htaccess .

Ou verifique se sua hospedagem mod_rewrite está habilitada criando um arquivo phpinfo.php com conteúdo,

<?php phpinfo();?>

Carregue este arquivo e navegue pelo navegador. Então você sabe quais módulos estão habilitados. Você precisa ativar o mod_rewrite para remover index.php do URL.

Mais detalhes Verifique este link

    
por Shahinul Islam 09.07.2013 / 09:45
2

Teve exatamente o mesmo problema. Mas no meu caso mod_rewrite não foi instalado para o apache. Acabei de instalar com

sudo a2enmod rewrite

e, em seguida, alterei meu Permalink Settings . Trabalhou como um encanto.

Espero que ajude.

    
por pratpor 31.07.2016 / 19:47

Tags