Multisite atrás do verniz

4

Estou tentando usar o verniz com um site wp 3.0.5 com Network (Multisite), quando eu acessar o URL do verniz, recebo esta mensagem:

Multisite only works without the port number in the URL.

Preciso de uma VCL personalizada para fazer isso funcionar? Estou usando a mesma configuração de backend para outros sites wordpress que funcionam bem ..

Se eu precisar perguntar isso no serverfault, me avise e eu perguntarei lá.

    
por Vid Luther 08.02.2011 / 23:16

2 respostas

2

Encontrei uma correção aqui: enlace

Você basicamente precisa modificar o wp-includes / ms-settings.php desta forma (remova as linhas '-'; adicione a linha '+'):

@@ -26,18 +26,8 @@
  if ( !isset( $current_site ) || !isset( $current_blog ) ) {
+        $_SERVER['HTTP_HOST'] = preg_replace( '|:\d+$|', '', $_SERVER['HTTP_HOST'] );
         $domain = addslashes( $_SERVER['HTTP_HOST'] );
-        if ( false !== strpos( $domain, ':' ) ) {
-               ....
-                        wp_die( /*WP_I18N_NO_PORT_NUMBER*/'Multisite only works without the port number in the URL.'/*/WP_I18N_NO_PORT_NUMBER*/ );
-                }
-        }
    
por webXL 09.02.2011 / 15:15
3

que a mensagem de erro do Wordpress é provavelmente enganosa.

O Wordpress procura pelo nome de domínio em $_SERVER['HTTP_HOST'] (Manual do PHP) e se contém um número de porta (separado com: como de costume, como enlace ), ele aceita apenas duas variantes: porta 80, uma porta 443.

Eu suponho que na sua configuração de verniz outras portas são dadas e assim você topar com essa.

Eu não sou especialista em verniz, mas é com isso que eu começaria a mexer. Primeiro de tudo, gostaria de produzir esse valor. O arquivo em questão é /wp-includes/ms-settings.php , ~ linha 38. Você pode começar a adicionar um var_dump($_SERVER['HTTP_HOST']); antes da instrução wp_die.

    
por hakre 09.02.2011 / 00:40