Resolução de problemas de um site da rede que exibe uma página em branco [fechada]

4

Eu tenho uma instalação do Wordpress no modo de rede, com subdomínios.

sitex.example.com está exibindo uma página em branco, sem nada no código-fonte.

Outros sites de rede são exibidos corretamente.

Eu renomei o tema que o site estava usando, mas ele não pegou Twenty Twelve em resposta.

Um verificador de resposta do servidor mostrou que o site está produzindo um código de 200 respostas.

Eu entrei no Network Admin e renomei sitex para sitey, mas sitey.example.com produziu uma página em branco também.

Eu verifiquei o .htaccess e ele contém o seguinte código:

RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]

# uploaded files
RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^ - [L]
RewriteRule . index.php [L]

Eu entrei no meu cPanel de hospedagem e confirmei que ainda tenho meu subdomínio curinga e não tenho um subdomínio manual para sitex no cPanel.

Voltei para o administrador de rede e alterei as configurações do site e defini o modelo & Folha de estilo para vinte e doze, mas isso não fez diferença.

Estou perdido.

Eu não sei o que mais poderia estar causando isso.

Você?

UPDATE

Se eu ativar a depuração, recebo o seguinte:

  

Aviso: inclua (/.../ wp-content / advanced-cache.php)   [function.include]: falha ao abrir fluxo: Nenhum arquivo ou diretório   em /wp-settings.php na linha 65

     

Aviso: include () [function.include]: falha na abertura   '/.../wp-content/advanced-cache.php' para inclusão   (include_path = '.: / usr / lib / php: / usr / local / lib / php') em /wp-settings.php   na linha 65

     

Aviso: o wpdb :: escape está obsoleto desde a versão 3.6! Usar   wpdb :: prepare () ou esc_sql () em vez disso. em   /.../wp-includes/functions.php on line 2913

     

Aviso: session_start () [function.session-start]: Não é possível enviar a sessão   limitador de cache - cabeçalhos já enviados (saída iniciada em   /.../wp-settings.php:65) em   /.../wp-content/plugins/nivo-slider/nivo-slider.php   na linha 10

    
por Steve 06.02.2014 / 12:33

3 respostas

0

Eu rede desativado um monte de plugins. Esses plug-ins estavam sendo executados no site do problema. Depois disso, o problema desapareceu.

    
por Steve 10.03.2014 / 04:01
2

O .htaccess não tem as informações para armazenar em cache o cache tão claro, a rede desativa seu plug-in de armazenamento em cache, bem como o plug-in do controle deslizante nivo. Se presente, remova a configuração para ativar o cache no wp-config também.

O /wp-admin.php carrega esse blog nesse ponto?

Se não, usando o phpmyadmin entre em wp_blogid_options para ver o que está sendo carregado. Você pode limpar essas opções e ver se o blog é carregado.

    
por LPH 11.02.2014 / 13:28
2

Desabilite o plugin Nivo Slider para confirmar que esta é a fonte do erro session_start. Isso definitivamente causaria uma página em branco. Eu estou olhando para a fonte do plugin e não há função session_start, então isso é um pouco estranho. Seu plugin está atualizado?

Como o erro diz "cabeçalhos já enviados (saída iniciada em /.../wp-settings.php:65)". Isso me leva a acreditar que há uma instância em cache de session_start que está causando um conflito. Com sorte, resolver o problema com o início da sessão permitirá que você continue usando o cache, se estiver funcionando corretamente.

Início da sessão

A função session_start deve ser executada antes de qualquer outro código. Especificamente, ele deve ser executado antes que o DOCTYPE e outras informações de cabeçalho sejam exibidas. A única maneira que conheço de executar session_start através do WordPress é conectar-se ao init (ou admin_init se o seu plugin for executado no CP do admin).% add_action('init', 'your_session_starting_function');

Outro plug-in usando o hook de inicialização pode causar um conflito se for executado antes do início de sua sessão.

Solucionando erros de cache

Verifique seu wp-config.php e, se existir, desative ou remova a linha define( 'WP_CACHE', true ); . Não apenas defina isso como falso.

Se você estiver usando um plugin de cache como o wp-cache, desabilite o cache. Se você estiver usando um plugin de minify, desative o minification.

    
por iyrin 11.02.2014 / 22:11