Upload de mídia com falha: "O arquivo enviado foi carregado apenas parcialmente".

4

Estou executando o Linux CentOS 5.8 e tenho minhas páginas da web usando o WordPress 4.0.

Estou tentando usar o WordPress em jpg photos para o servidor, mas ele falha aleatoriamente. Enviei algumas fotos e recebi erros como:

“4.JPG” has failed to upload due to an error
The uploaded file was only partially uploaded.

Então eu tento de novo e de novo e de novo até que seja carregado com sucesso. Muito frustrante.

Como posso depurar isso? Existe um arquivo de log? Onde procurar?

    
por Danijel 29.01.2015 / 14:56

4 respostas

0

Consegui resolver esse problema com a alteração da configuração do servidor Apache: há um sinalizador KeepAlive que precisa ser desativado.

Mais sobre este sinalizador:

Otimização do Apache: Ativar ou desativar o recurso KeepAlive?

    
por Danijel 17.08.2015 / 10:13
1

Eu resolvi adicionando

<?php header ("Connection: close"); ?> 

em file.php situado em wp-admin / include

    
por hashtagerrors 14.11.2016 / 06:05
0

Eu me deparei com o mesmo problema e tentei fazer uma pesquisa no Google e recebi tantas sugestões técnicas que não consegui nem começar, já que não sou especialista em tecnologia. Eu encontrei um artigo onde um blogueiro disse que ela contatou seu servidor de hospedagem e eles mudaram a versão do PHP. Pode ou não funcionar para mim, mas eu vou tentar.

Só que eu não sabia como fazer isso e acabei de sair com o suporte ao cliente e basicamente o que ele fez foi aumentar minha largura de banda. Ainda não consegui fazer o upload. Eu disse a ele na página adicionar biblioteca de mídia que ele disse que o tamanho máximo do arquivo de upload era de 2MB. Mas não foi até eu atualizar a página que a mudança entrou em ação e eu vi o meu tamanho máximo de arquivo de upload foi de 256 MB. Depois disso, consegui fazer upload de fotos muito bem!

    
por user77871 17.08.2015 / 08:45
0

Eu resolvi isso removendo o libapache2-mod-php5filter:

apt-get remove libapache2-mod-php5filter

e instalando o libapache2-mod-php5:

apt-get install libapache2-mod-php5
    
por Jo Smo 11.11.2016 / 10:11