Não é possível fazer login no novo domínio personalizado em vários sites?

4

Plano de fundo

Eu configurei o WordPress Multisite há um tempo atrás. Eu adicionei um em um domínio personalizado e mais em subdomínios do site principal. Desde então, adicionei mais subdomínios e até agora tudo funcionou bem.

Problema

Adicionei outro em um domínio personalizado e, por algum motivo, não consigo fazer login nele. Cada tentativa de login redireciona para a página de login novamente. Todos os outros domínios existentes ainda funcionam bem.

O que eu tentei

Tenho certeza de que é relacionado a cookies. Consegui fazer o login uma vez, redefinindo a senha, mas ela não fez login novamente. Eu tentei vários navegadores para ver se esse era o problema.

Eu verifiquei o .htaccess para ver se havia diretivas especiais para qualquer um dos domínios personalizados e não encontrei nada. Eu comparei as configurações para ambos os sites (do painel do Network Admin) e não vi nada fora do comum.

    
por Jim McKeeth 11.10.2012 / 21:16

1 resposta

2

Encontrei a resposta. Eu não tinha executado o plug-in de mapeamento de domínio antes de alterná-lo para um domínio personalizado. Então, os passos corretos devem ser assim:

  1. Criar novo site como um subdomínio (site.example.com)
  2. Point sub-domain at root (example.com)
  3. Aponte o domínio personalizado (site.com) na raiz (example.com)
  4. Visite a página de administração para o subdomínio (site.example.com)
  5. Adicionar domínio personalizado (site.com) ao plug-in de mapeamento de domínio
  6. Visite o domínio personalizado (site.com)

Esqueci o passo 5 e tentei apenas editar o site para estar no domínio personalizado em vez do subdomínio.

    
por Jim McKeeth 13.10.2012 / 04:24