Criado um tipo de postagem personalizado - não é possível visualizá-lo

3

Eu criei um tipo de post personalizado ("Portfolio") e posso criar as postagens perfeitamente bem. O problema é quando eu vou ver o item, ele me dá um erro 404.

Aqui está o item do portfólio

Aqui está o meu código para registrar o tipo de postagem personalizado:

add_action( 'init', 'create_post_type' );
  function create_post_type() {
    $labels = array(
        'name' => __('Portfolio'),
        'singular_name' => __('Portfolio Item'),
        'add_new' => __('Add New'),
        'add_new_item' => __('Add New Portfolio Item'),
        'edit_item' => __('Edit Portfolio Item'),
        'new_item' => __('New Portfolio Item'),
        'view_item' => __('View Portfolio Item'),
        'search_items' => __('Search Portfolio'),
        'not_found' =>  __('Nothing found'),
        'not_found_in_trash' => __('Nothing found in Trash'),
        'parent_item_colon' => ''
    );

    $args = array(
        'labels' => $labels,
        'public' => true,
        'publicly_queryable' => true,
        'show_ui' => true,
        'query_var' => true,
        'menu_icon' => null,
        'rewrite' => true,
        'capability_type' => 'post',
        'hierarchical' => false,
        'menu_position' => null,
        'supports' => array('title','editor','thumbnail','excerpt','comments')
    );
    register_post_type( 'portfolio' , $args );      
}

Estou sentindo falta de algo, mas não sei o quê. Socorro! Agradecemos antecipadamente:)

    
por Tara 09.09.2013 / 13:41

2 respostas

5

Faça o seguinte e tente.

  1. Regras de reescrita do Flush (Verifique o link insira a descrição do link aqui ).
  2. Atualize seu permalink.
por hariprasad 09.09.2013 / 13:51
4

Tente regenerar seus permalinks.

Vá para Configurações / Permalinks e clique no botão Salvar .

    
por Arda Basoglu 14.08.2014 / 14:17