Links simbólicos na caixa dev com plugins e folhas de estilo

11

Estou usando o mac os x 10.6 com o xampp.

http://wp3.1/ é o URL para onde eu tenho o WordPress instalado.

O caminho físico é /Users/myUserName/Sites/wp3.1/

Eu não instalo plugins ou temas da maneira "natural". Eu criei um diretório chamado "git", que está localizado em /Users/myUserName/git/ . É aqui que todos os meus repositórios git vivem. Quando quero instalar um plugin, acabei de criar um link simbólico em /Users/myUserName/Sites/wp3.1/wp-content/plugins/ . Isso funciona muito bem para plugins simples, mas se o plugin enfileirar for uma folha de estilo ou script, o URL será exibido como:

http://wp3.1/wp-content/plugins/Users/myUserName/git/options-framework-plugin/css/colorpicker.css?ver=3.1.1

Como corrijo isso?

    
por mfields 24.04.2011 / 02:38

2 respostas

10

Links simbólicos são… risky no WordPress. É mais fácil usar um domínio separado para plugins por wp-config.php:

define( 'WP_PLUGIN_DIR', '/local/path/to/plugin/directory' );
define( 'WP_PLUGIN_URL', 'http://plugins.dev');

Veja Estratégia para criar plug-in usando o Eclipse como um exemplo de configuração IDE com essa configuração.

    
por fuxia 24.04.2011 / 02:48
0

Como você pode ver, o URL do plug-in está correto, exceto pelo caminho real preso no meio. Podemos filtrar a função responsável por gerar URLs de plugins e remover isso.

O código a seguir deve ser instalado como um Deve usar o plug-in :

add_filter( 'plugins_url', function( $url ) {
    return str_replace( '/Users/myUserName/git/', '', $url );
});
    
por shea 20.08.2013 / 11:48